Sunday, February 05, 2006

Talk Now!

Back in December, I purchased a language learning CD at a local CompuSmart.

A company called Eurotalk produces the programme and in North America, a company called Topics Entertainment distributes it.

This makes for a funny situation and not a particularly appealing one.

The actual programme is titled, "Talk Now!"

What I purchased however is titled, "Instant Immersion v2.0".

When I attempted to install it, it didn't work. Something ran, some sort of shell, but the content is missing. Every screen is supposed to have Help support but these were all blank. Nothing worked in any useful way.

Looking at the packaging, I found a website link and went there. I found a website that was only a catalogue of products to purchase. I'd already purchased their product and now I wanted it to work.

After some research, I found out about this Eurotalk company and tried to track them down. Nothing is easy. Their website is not straightforward, not even the URL is… www.eurotalk.co.uk redirects to .com but not in my web browser.

Eventually, I find a support page which for the most part, is happy to tell me that the programme is actually designed on Macs and therefore is well supported. But it still didn't work.

I gave up.

Today, on a whim, I tried to make it work again. I'd already spent some time configuring my camera network again so I was in the mood for grief. I copied the app to the Applications folder again and then using IE, managed to work the site. As an added bonus, the product I bought isn't anywhere to be found because of course, it isn't sold by Eurotalk, it's sold by Topics.

Somewhere in the support text, it states that if certain things aren't showing up, then you need to trash the prefs and re-run the app.

I tried it but it didn't work. I read some more. It turns out that you can't install the app on your hard drive. You have to run it from the CD. Not only do you need to have the CD in the drive, but the app itself must be run from the CD. YUCK!

At least, now I understood the situation and could get the app to run with all of the intended features. A few minutes creating a disk image and now I can eject the CD.

I feel better now.

2 Comments:

At 8:26 p.m. , Anonymous Anonymous said...

You get this to work? What language are you learning?

 
At 1:45 p.m. , Blogger Canicus said...

Well, once I'm willing to put the time in, I've got the Spanish CD.

If it looks decent, then I'll try the French.

But yeah, it does work.

 

Post a Comment

Subscribe to Post Comments [Atom]

Links to this post:

Create a Link

<< Home